aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@flameeyes.eu>2012-06-29 13:01:26 -0700
committerHarald Welte <laforge@gnumonks.org>2012-06-30 22:01:43 +0200
commit200710e3eb9617897be2698077cf77909603f245 (patch)
tree7cb20ba92e66790051902418b12f56500c767e3c /Makefile.am
parent7e007e0f87c4a06396ef46081ef1d69a4bdc11ae (diff)
build: use default htmldir directory.
Signed-off-by: Diego Elio Pettenò <flameeyes@flameeyes.eu>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 4 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index d135e7ff..d0fb027a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -17,12 +17,9 @@ EXTRA_DIST = git-version-gen
if HAVE_DOXYGEN
-pkgdocdir=$(docdir)/$(PACKAGE)-$(VERSION)
-doc_htmldir=$(pkgdocdir)/html
+html_DATA = $(top_builddir)/doc/html.tar
-doc_html_DATA = $(top_builddir)/doc/html.tar
-
-$(doc_html_DATA): $(top_builddir)/doc/core/html/index.html \
+$(html_DATA): $(top_builddir)/doc/core/html/index.html \
$(top_builddir)/doc/gsm/html/index.html \
$(top_builddir)/doc/vty/html/index.html \
$(top_builddir)/doc/codec/html/index.html
@@ -49,10 +46,10 @@ $(top_builddir)/doc/codec/html/index.html: $(SOURCES) Doxyfile.codec
$(DOXYGEN) Doxyfile.codec
install-data-hook:
- cd $(DESTDIR)$(doc_htmldir) && tar xf html.tar && rm -f html.tar
+ cd $(DESTDIR)$(htmldir) && tar xf html.tar && rm -f html.tar
uninstall-hook:
- cd $(DESTDIR)$(doc_htmldir) && rm -rf {core,gsm,vty,codec}
+ cd $(DESTDIR)$(htmldir) && rm -rf {core,gsm,vty,codec}
DX_CLEAN = doc/{core,gsm,vty,codec}/{html,latex}/* doc/html.tar
endif