aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2011-06-23 14:14:20 +0200
committerHarald Welte <laforge@gnumonks.org>2011-06-23 14:14:20 +0200
commit9b21e88367eea8cdf200cf06fae99dec06e712a7 (patch)
tree14a065f42c91774ea90b190ee13997859e1ac5c3
parent0849c9af2a5637da5ce24118e2f4b9ab9da9c6d9 (diff)
add new 'prim.h' header file for primitives
-rw-r--r--include/osmocom/core/Makefile.am2
-rw-r--r--include/osmocom/core/prim.h20
2 files changed, 21 insertions, 1 deletions
diff --git a/include/osmocom/core/Makefile.am b/include/osmocom/core/Makefile.am
index 3c30362c..1ef37693 100644
--- a/include/osmocom/core/Makefile.am
+++ b/include/osmocom/core/Makefile.am
@@ -1,6 +1,6 @@
osmocore_HEADERS = signal.h linuxlist.h timer.h select.h msgb.h bits.h \
bitvec.h statistics.h utils.h socket.h \
- gsmtap.h write_queue.h \
+ gsmtap.h write_queue.h prim.h \
logging.h rate_ctr.h gsmtap_util.h \
plugin.h crc16.h panic.h process.h msgfile.h \
backtrace.h conv.h application.h
diff --git a/include/osmocom/core/prim.h b/include/osmocom/core/prim.h
new file mode 100644
index 00000000..5494f3c3
--- /dev/null
+++ b/include/osmocom/core/prim.h
@@ -0,0 +1,20 @@
+#ifndef OSMO_PRIMITIVE_H
+#define OSMO_PRIMITIVE_H
+
+#include <stdint.h>
+
+enum osmo_prim_operation {
+ PRIM_OP_REQUEST,
+ PRIM_OP_RESPONSE,
+ PRIM_OP_INDICATION,
+ PRIM_OP_CONFIRM,
+};
+
+struct osmo_prim_hdr {
+ unsigned int sap;
+ unsigned int primitive;
+ enum osmo_prim_operation operation;
+ struct msgb *msg; /* message containing associated data */
+};
+
+#endif