aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2011-06-26 14:33:57 +0200
committerHarald Welte <laforge@gnumonks.org>2011-06-26 14:40:12 +0200
commit94df39e905b9de424ecb40e9c54ddae0e7b6d4e3 (patch)
tree0aeaad484504b3c842d1f52293b57e19aa4c2e81
parent2aee7b14ca17995fc311eb2d7d99c23f734adad6 (diff)
add some utility functions for paging related calculation (TS 05.02)
-rw-r--r--include/osmocom/gsm/Makefile.am2
-rw-r--r--include/osmocom/gsm/gsm0502.h35
-rw-r--r--src/gsm/gsm48.c14
3 files changed, 43 insertions, 8 deletions
diff --git a/include/osmocom/gsm/Makefile.am b/include/osmocom/gsm/Makefile.am
index aa7b1a9a..ce3ac9cb 100644
--- a/include/osmocom/gsm/Makefile.am
+++ b/include/osmocom/gsm/Makefile.am
@@ -1,6 +1,6 @@
osmogsm_HEADERS = a5.h comp128.h gsm0808.h gsm48_ie.h mncc.h rxlev_stat.h \
gsm0480.h gsm48.h gsm_utils.h rsl.h tlv.h abis_nm.h \
- sysinfo.h prim.h
+ sysinfo.h prim.h gsm0502.h
SUBDIRS = protocol
diff --git a/include/osmocom/gsm/gsm0502.h b/include/osmocom/gsm/gsm0502.h
new file mode 100644
index 00000000..de92c636
--- /dev/null
+++ b/include/osmocom/gsm/gsm0502.h
@@ -0,0 +1,35 @@
+#ifndef OSMOCOM_GSM_0502_H
+#define OSMOCOM_GSM_0502_H
+
+#include <stdint.h>
+
+#include <osmocom/gsm/protocol/gsm_04_08.h>
+#include <osmocom/gsm/protocol/gsm_08_58.h>
+
+/* Table 5 Clause 7 TS 05.02 */
+static inline unsigned int
+gsm0502_get_n_pag_blocks(struct gsm48_control_channel_descr *chan_desc)
+{
+ if (chan_desc->ccch_conf == RSL_BCCH_CCCH_CONF_1_C)
+ return 3 - chan_desc->bs_ag_blks_res;
+ else
+ return 9 - chan_desc->bs_ag_blks_res;
+}
+
+/* Chapter 6.5.2 of TS 05.02 */
+static inline unsigned int
+gsm0502_get_ccch_group(uint64_t imsi, unsigned int bs_cc_chans,
+ unsigned int n_pag_blocks)
+{
+ return (imsi % 1000) % (bs_cc_chans * n_pag_blocks) / n_pag_blocks;
+}
+
+/* Chapter 6.5.2 of TS 05.02 */
+static inline unsigned int
+gsm0502_get_paging_group(uint64_t imsi, unsigned int bs_cc_chans,
+ int n_pag_blocks)
+{
+ return (imsi % 1000) % (bs_cc_chans * n_pag_blocks) % n_pag_blocks;
+}
+
+#endif
diff --git a/src/gsm/gsm48.c b/src/gsm/gsm48.c
index 4645af4d..44baec60 100644
--- a/src/gsm/gsm48.c
+++ b/src/gsm/gsm48.c
@@ -31,6 +31,7 @@
#include <osmocom/core/utils.h>
#include <osmocom/gsm/tlv.h>
#include <osmocom/gsm/gsm48.h>
+#include <osmocom/gsm/gsm0502.h>
#include <osmocom/gsm/protocol/gsm_04_08.h>
#include <osmocom/gsm/protocol/gsm_08_58.h>
@@ -418,11 +419,10 @@ int gsm48_construct_ra(uint8_t *buf, const struct gprs_ra_id *raid)
/* From Table 10.5.33 of GSM 04.08 */
int gsm48_number_of_paging_subchannels(struct gsm48_control_channel_descr *chan_desc)
{
- if (chan_desc->ccch_conf == RSL_BCCH_CCCH_CONF_1_C) {
- return OSMO_MAX(1, (3 - chan_desc->bs_ag_blks_res))
- * (chan_desc->bs_pa_mfrms + 2);
- } else {
- return (9 - chan_desc->bs_ag_blks_res)
- * (chan_desc->bs_pa_mfrms + 2);
- }
+ unsigned int n_pag_blocks = gsm0502_get_n_pag_blocks(chan_desc);
+
+ if (chan_desc->ccch_conf == RSL_BCCH_CCCH_CONF_1_C)
+ return OSMO_MAX(1, n_pag_blocks) * (chan_desc->bs_pa_mfrms + 2);
+ else
+ return n_pag_blocks * (chan_desc->bs_pa_mfrms + 2);
}