aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2015-12-22 22:22:23 +0100
committerHarald Welte <laforge@gnumonks.org>2015-12-22 23:03:41 +0100
commitbf49cc1c0074055cecbf8346e41455d5c7bb0a71 (patch)
tree3f355e9af03d1a1c301a71af46e4bfc4e411babd /src/Makefile.am
parent46c2945af2f7d6741fdba7185241845f1d2c7421 (diff)
Import SUA (SCCP User Adaptation) and SCCP User SAP
... this code originates from the osmo-iuh repository, but is now part of a new shared libosmo-sigtran.so library generated in this repository.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am22
1 files changed, 21 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index fa47e85..ba55162 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,9 +1,29 @@
AM_CPPFLAGS = $(all_includes) -I$(top_srcdir)/include -I$(top_builddir)
AM_CFLAGS=-Wall $(LIBOSMOCORE_CFLAGS)
+# Legacy static libs
+
sccpdir = $(libdir)
sccp_LIBRARIES = libsccp.a libmtp.a libxua.a
libsccp_a_SOURCES = sccp.c
-libmtp_a_SOURCES = mtp_pcap.c
+libmtp_a_SOURCES = mtp_pcap.c
libxua_a_SOURCES = xua_msg.c
+# ensure that the file for the static lib is built with different C
+# flags, working around automake complaining that xua_msg.o is built
+# both with libtool (below) and without (here)
+libxua_a_CPPFLAGS = $(AM_CPPFLAGS) -DDUMMY -UDUMMY
+
+
+# New shared lib
+
+lib_LTLIBRARIES = libosmo-sigtran.la
+
+# This is _NOT_ the library release version, it's an API version.
+# Please read Chapter 6 "Library interface versions" of the libtool
+# documentation before making any modification
+LIBVERSION=0:0:0
+
+libosmo_sigtran_la_SOURCES = sccp_sap.c sua.c xua_msg.c
+libosmo_sigtran_la_LDFLAGS = -version-info $(LIBVERSION) -no-undefined -export-symbols-regex '^osmo_'
+libosmo_sigtran_la_LIBADD = $(LIBOSMOCORE_LIBS) $(LIBOSMONETIF_LIBS) $(LIBSCTP_LIBS)