aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNeels Hofmeyr <nhofmeyr@sysmocom.de>2016-10-01 00:49:54 +0200
committerNeels Hofmeyr <nhofmeyr@sysmocom.de>2016-10-01 01:00:52 +0200
commitd6c7da8cc94289cfef47e7f998c068ecfe7c843c (patch)
tree83aa4407a03d983bb8d029e760fb644b0e82da7f /configure.ac
parent48372dad0edb96b4dce194481765a6ad3ad7eb56 (diff)
configure: check for pkg-config presence
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d2501a6..6446677 100644
--- a/configure.ac
+++ b/configure.ac
@@ -19,6 +19,13 @@ AC_PROG_INSTALL
LT_INIT
AC_PROG_LIBTOOL
+dnl check for pkg-config (explained in detail in libosmocore/configure.ac)
+AC_PATH_PROG(PKG_CONFIG_INSTALLED, pkg-config, no)
+if test "x$PKG_CONFIG_INSTALLED" = "xno"; then
+ AC_MSG_WARN([You need to install pkg-config])
+fi
+PKG_PROG_PKG_CONFIG([0.20])
+
PKG_CHECK_MODULES(LIBOSMOCORE, libosmocore >= 0.3.0)
PKG_CHECK_MODULES(LIBOSMONETIF, libosmo-netif >= 0.0.6)