aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2010-07-30 02:13:37 +0800
committerHolger Hans Peter Freyther <zecke@selfish.org>2010-07-30 02:13:37 +0800
commit17097d06b54f59d63f357504fd27e5e81b63ec9a (patch)
tree4b56427ca78620fa8aeaf2f60e351ae239653d0d /Makefile.am
parente4cb3e039b78e03dc7115faac065830dada67a17 (diff)
sccp: Add a new buildsystem for the OSMO SCCP library
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..39cfd2f
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,13 @@
+AUTOMAKE_OPTIONS = foreign dist-bzip2 1.6
+
+INCLUDES = $(all_includes) -I$(top_srcdir)/include
+SUBDIRS = include src tests
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = libsccp.pc
+
+BUILT_SOURCES = $(top_srcdir)/.version
+$(top_srcdir)/.version:
+ echo $(VERSION) > $@-t && mv $@-t $@
+dist-hook:
+ echo $(VERSION) > $(distdir)/.tarball-version