aboutsummaryrefslogtreecommitdiffstats
path: root/tests/osmo-pcap-test/Makefile.am
diff options
context:
space:
mode:
authorPablo Neira Ayuso <pablo@gnumonks.org>2012-06-28 12:53:45 +0200
committerPablo Neira Ayuso <pablo@netfilter.org>2012-06-28 16:42:22 +0200
commit75755dd7d948992d6c5d05f298559f01b511607d (patch)
treefa6276508c9ef6f1c8e5a16238b6d2149b3e9a52 /tests/osmo-pcap-test/Makefile.am
parent729a0917ac17e2c5a70ab24cc884ff68a7df52af (diff)
test: add osmo-pcap-test infrastructure
This patch adds the osmo-pcap-test infrastructure that allows you to take packets stored in one pcap file, convert them to msgb and pass it to some function. The infrastructure also provides timing reconstruction based on the pcap file information. This is useful for easy protocol development, automated testing and fuzzying of the existing code to validate the code. Signed-off-by: Pablo Neira Ayuso <pablo@gnumonks.org>
Diffstat (limited to 'tests/osmo-pcap-test/Makefile.am')
-rw-r--r--tests/osmo-pcap-test/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/osmo-pcap-test/Makefile.am b/tests/osmo-pcap-test/Makefile.am
new file mode 100644
index 0000000..6420faf
--- /dev/null
+++ b/tests/osmo-pcap-test/Makefile.am
@@ -0,0 +1,12 @@
+include $(top_srcdir)/Make_global.am
+
+check_PROGRAMS = osmo-pcap-test
+
+osmo_pcap_test_SOURCES = proto.c \
+ l3_ipv4.c \
+ l4_tcp.c \
+ l4_udp.c \
+ main.c
+
+osmo_pcap_test_LDFLAGS = -lpcap \
+ -losmocore