aboutsummaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorOliver Smith <osmith@sysmocom.de>2019-03-13 17:10:03 +0100
committerosmith <osmith@sysmocom.de>2019-03-14 12:03:29 +0000
commit1ab218d28f684a431cd9de972499b987b63a507a (patch)
tree90a4bea565a2ab21972ee66091417fc4c9f53d84 /tests/Makefile.am
parent3d8022adf0640072c401056a902a52084950891c (diff)
tests: AM_LDFLAGS = -noinstall for all tests
Fix a symbol lookup error when building a new test on systems where a previous libosmonetif.so is installed. Symptoms described here in detail: https://osmocom.org/issues/3812#note-10 -no-install causes libtool to generate output files that link against libraries in the build tree, instead of linking against the future installation paths and generating a wrapper script. The wrapper script should override the library paths, but at least on Debian, it does not work as it should. Test binaries won't be installed anyway, so we can safely use -no-install and work around the problem. See also: https://autotools.io/libtool/wrappers.html https://www.gnu.org/software/libtool/manual/html_node/Link-mode.html Related: OS#3812 Change-Id: I94ccff42dfba71aaf59bb30ca312db0bac58c27d
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 36447be..dd7703a 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,5 +1,5 @@
AM_CFLAGS = -Wall -I$(top_srcdir)/include $(LIBOSMOCORE_CFLAGS) -g
-AM_LDFLAGS = $(LIBOSMOCORE_LDFLAGS)
+AM_LDFLAGS = $(LIBOSMOCORE_LDFLAGS) -no-install
check_PROGRAMS = osmux/osmux_test osmux/osmux_test2 stream/stream_test jibuf/jibuf_test amr/amr_test
check_HEADERS =
@@ -12,7 +12,6 @@ osmux_osmux_test2_LDADD = $(LIBOSMOCORE_LIBS) $(LIBOSMOGSM_LIBS) $(top_builddir)
stream_stream_test_SOURCES = stream/stream_test.c
stream_stream_test_LDADD = $(LIBOSMOCORE_LIBS) $(LIBOSMOGSM_LIBS) $(top_builddir)/src/libosmonetif.la
-stream_stream_test_LDFLAGS = -no-install
jibuf_jibuf_test_SOURCES = jibuf/jibuf_test.c
jibuf_jibuf_test_LDADD = $(LIBOSMOCORE_LIBS) $(LIBOSMOGSM_LIBS) $(top_builddir)/src/libosmonetif.la