aboutsummaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorPhilipp Maier <pmaier@sysmocom.de>2019-02-27 12:29:19 +0100
committerPhilipp Maier <pmaier@sysmocom.de>2019-03-07 10:22:22 +0100
commitfa7df8726001146c902d3a93e2a4b425fa9024b0 (patch)
tree69f5ad07e901d1bdc2f1d74cdd8b668c9da5e6fe /tests/Makefile.am
parent0fe9b3664a8d0b74d5e1c67593b350d67de3f98f (diff)
AMR: add functions to convert between bw-efficient and octet-alignedpmaier/amrmangle
RFC 3267 describes two different AMR frame formats. Octet Aligned and Bandwidth efficient mode. In Bandwith efficient mode the padding bits, which are used to align CMR, TOC and payload on octet boundaries are saved and the fielda are packed directly one after another. - Add functions to convert from one mode to the other and vice versa. - Add function to detect in which mode an AMR frame is encoded. Change-Id: I5b5a0fa644d8dbb1f04f9d7e35312683c7b3d196 Related: SYS#4470
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index c3628ac..36447be 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,7 +1,7 @@
AM_CFLAGS = -Wall -I$(top_srcdir)/include $(LIBOSMOCORE_CFLAGS) -g
AM_LDFLAGS = $(LIBOSMOCORE_LDFLAGS)
-check_PROGRAMS = osmux/osmux_test osmux/osmux_test2 stream/stream_test jibuf/jibuf_test
+check_PROGRAMS = osmux/osmux_test osmux/osmux_test2 stream/stream_test jibuf/jibuf_test amr/amr_test
check_HEADERS =
osmux_osmux_test_SOURCES = osmux/osmux_test.c
@@ -17,6 +17,9 @@ stream_stream_test_LDFLAGS = -no-install
jibuf_jibuf_test_SOURCES = jibuf/jibuf_test.c
jibuf_jibuf_test_LDADD = $(LIBOSMOCORE_LIBS) $(LIBOSMOGSM_LIBS) $(top_builddir)/src/libosmonetif.la
+amr_amr_test_SOURCES = amr/amr_test.c
+amr_amr_test_LDADD = $(LIBOSMOCORE_LIBS) $(LIBOSMOGSM_LIBS) $(top_builddir)/src/libosmonetif.la
+
if HAVE_PCAP
check_PROGRAMS += jibuf/jibuf_tool
check_HEADERS += \
@@ -63,7 +66,9 @@ EXTRA_DIST = testsuite.at $(srcdir)/package.m4 $(TESTSUITE) \
osmux/osmux_test2.ok \
stream/stream_test.ok \
stream/stream_test.err \
- jibuf/jibuf_test.ok
+ jibuf/jibuf_test.ok \
+ amr/amr_test.ok
+
DISTCLEANFILES = atconfig