aboutsummaryrefslogtreecommitdiffstats
path: root/examples/Makefile.am
diff options
context:
space:
mode:
authorMax <msuraev@sysmocom.de>2017-10-13 15:30:54 +0200
committerMax <msuraev@sysmocom.de>2017-10-13 18:13:14 +0200
commit8440357d4cc88479921350344e435ee9c5e4e0f1 (patch)
tree9f168c3fc7d5d3595f7428745120bf674fed5e68 /examples/Makefile.am
parentfae8559ff5ce825a874eeb33b2f1053430c07dc3 (diff)
examples: add simple UDP client/server
In addition to showing basic UDP send/receive example, it helps to test corner-case when dealing with 0-length UDP packets. Change-Id: I08c0adf1cf9b6a6f1f7090b237d0497c2ec13cdf Related: OS#2219
Diffstat (limited to 'examples/Makefile.am')
-rw-r--r--examples/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
index ddfaa48..df13808 100644
--- a/examples/Makefile.am
+++ b/examples/Makefile.am
@@ -14,9 +14,13 @@ noinst_PROGRAMS = ipa-stream-client \
rs232-write \
rtp-udp-test-client \
rtp-udp-test-server \
+ udp-test-client \
+ udp-test-server \
osmux-test-input \
osmux-test-output
+noinst_HEADERS = udp-test.h
+
ipa_stream_client_SOURCES = ipa-stream-client.c
ipa_stream_client_LDADD = $(top_builddir)/src/libosmonetif.la \
$(LIBOSMOCORE_LIBS) $(LIBOSMOGSM_LIBS)
@@ -57,6 +61,12 @@ rtp_udp_test_server_SOURCES = rtp-udp-test-server.c
rtp_udp_test_server_LDADD = $(top_builddir)/src/libosmonetif.la \
$(LIBOSMOCORE_LIBS) $(LIBOSMOGSM_LIBS)
+udp_test_client_SOURCES = udp-test-client.c
+udp_test_client_LDADD = $(top_builddir)/src/libosmonetif.la $(LIBOSMOCORE_LIBS) $(LIBOSMOGSM_LIBS)
+
+udp_test_server_SOURCES = udp-test-server.c
+udp_test_server_LDADD = $(top_builddir)/src/libosmonetif.la $(LIBOSMOCORE_LIBS) $(LIBOSMOGSM_LIBS)
+
osmux_test_input_SOURCES = osmux-test-input.c
osmux_test_input_LDADD = $(top_builddir)/src/libosmonetif.la \
$(LIBOSMOCORE_LIBS) $(LIBOSMOGSM_LIBS)