aboutsummaryrefslogtreecommitdiffstats
path: root/examples/Makefile.am
diff options
context:
space:
mode:
authorPablo Neira Ayuso <pablo@gnumonks.org>2012-01-24 14:32:37 +0100
committerPablo Neira Ayuso <pablo@netfilter.org>2012-02-23 13:44:26 +0100
commit72cd95b3527ee45639f0445817781afc3e732f45 (patch)
treeae72c9aa167320b8c12cfbc9ab3700d2037f6d1d /examples/Makefile.am
parent2b5d3ce7c69e1149bb2af815ab8b8534026063ca (diff)
add RTP support
This patch adds the initial RTP support for libosmo-netif, it's based on Harald's RTP support available in openBSC. I have also added a couple of example to show how our new channel infrastructure interacts with the RTP layer. Signed-off-by: Pablo Neira Ayuso <pablo@gnumonks.org>
Diffstat (limited to 'examples/Makefile.am')
-rw-r--r--examples/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
index 173b620..c9849db 100644
--- a/examples/Makefile.am
+++ b/examples/Makefile.am
@@ -9,7 +9,9 @@ noinst_PROGRAMS = ipa-stream-client \
lapd-over-datagram-user \
lapd-over-datagram-network \
stream-client \
- stream-server
+ stream-server \
+ rtp-udp-test-client \
+ rtp-udp-test-server
ipa_stream_client_SOURCES = ipa-stream-client.c
ipa_stream_client_LDADD = $(top_builddir)/src/libosmonetif.la \
@@ -36,3 +38,11 @@ stream_client_LDADD = $(top_builddir)/src/libosmonetif.la \
stream_server_SOURCES = stream-server.c
stream_server_LDADD = $(top_builddir)/src/libosmonetif.la \
$(LIBOSMOCORE_LIBS) $(LIBOSMOGSM_LIBS)
+
+rtp_udp_test_client_SOURCES = rtp-udp-test-client.c
+rtp_udp_test_client_LDADD = $(top_builddir)/src/libosmonetif.la \
+ $(LIBOSMOCORE_LIBS) $(LIBOSMOGSM_LIBS)
+
+rtp_udp_test_server_SOURCES = rtp-udp-test-server.c
+rtp_udp_test_server_LDADD = $(top_builddir)/src/libosmonetif.la \
+ $(LIBOSMOCORE_LIBS) $(LIBOSMOGSM_LIBS)