aboutsummaryrefslogtreecommitdiffstats
path: root/examples/Makefile.am
diff options
context:
space:
mode:
authorPablo Neira Ayuso <pablo@gnumonks.org>2011-10-17 19:49:33 +0200
committerPablo Neira Ayuso <pablo@netfilter.org>2011-10-17 22:12:42 +0200
commit20c660caecc95b03489f870945ae9fe91c839bd3 (patch)
tree77a64e776b56212768574aa8e3bd2a48136969eb /examples/Makefile.am
parent1434e40951a4eda107e2e81425f99a2d5de23975 (diff)
ipa: initial addition of helper functions and examples
This patch adds IPA helper function that can be use on top of stream sockets. The current API is just a copy and paste from libosmo-abis, it will change in follow up patches to improve it.
Diffstat (limited to 'examples/Makefile.am')
-rw-r--r--examples/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
index 39e7207..be4ecde 100644
--- a/examples/Makefile.am
+++ b/examples/Makefile.am
@@ -2,11 +2,21 @@ INCLUDES = $(all_includes) -I$(top_srcdir)/include
AM_CFLAGS=-Wall -g $(LIBOSMOCORE_CFLAGS) $(LIBOSMOGSM_CFLAGS) $(LIBOSMOABIS_CFLAGS) $(COVERAGE_CFLAGS)
AM_LDFLAGS = $(COVERAGE_LDFLAGS)
-noinst_PROGRAMS = lapd-over-datagram-user \
+noinst_PROGRAMS = ipa-stream-client \
+ ipa-stream-server \
+ lapd-over-datagram-user \
lapd-over-datagram-network \
stream-client \
stream-server
+ipa_stream_client_SOURCES = ipa-stream-client.c
+ipa_stream_client_LDADD = $(top_builddir)/src/libosmonetif.la \
+ $(LIBOSMOCORE_LIBS) $(LIBOSMOGSM_LIBS)
+
+ipa_stream_server_SOURCES = ipa-stream-server.c
+ipa_stream_server_LDADD = $(top_builddir)/src/libosmonetif.la \
+ $(LIBOSMOCORE_LIBS) $(LIBOSMOGSM_LIBS)
+
lapd_over_datagram_user_SOURCES = lapd-over-datagram-user.c
lapd_over_datagram_user_LDADD = $(top_builddir)/src/libosmonetif.la \
$(LIBOSMOCORE_LIBS) $(LIBOSMOGSM_LIBS) \