aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorMax <msuraev@sysmocom.de>2016-12-21 14:35:21 +0100
committerMax <msuraev@sysmocom.de>2016-12-21 18:05:27 +0100
commitc9a86ff30636c1c7cf2af2f246796e622ed01169 (patch)
tree975b598492ff27eec774635a171f26ce046a92c2 /debian
parenteda74fafb40e1c760a0cafd095d0fa91a23b66f0 (diff)
Integrate Debian packaging changes
debian/control: * restructure to make it easier to incorporate further changes * update package descriptions * update project URL debian/rules: * use proper hardening syntax * restructure to make it easier to incorporate further changes * add cleanup override debian/copyright: add file matching Debian format Change-Id: I9174b34a79c0562ef43f757ea76d67301088f109 Related: OS#1694
Diffstat (limited to 'debian')
-rw-r--r--debian/control41
-rw-r--r--debian/copyright51
-rwxr-xr-xdebian/rules7
3 files changed, 93 insertions, 6 deletions
diff --git a/debian/control b/debian/control
index 3953414..f499728 100644
--- a/debian/control
+++ b/debian/control
@@ -2,24 +2,50 @@ Source: libosmo-netif
Section: libs
Priority: optional
Maintainer: Holger Hans Peter Freyther <holger@moiji-mobile.com>
-Build-Depends: debhelper (>= 9), autotools-dev, autoconf, automake, libtool, dh-autoreconf, libdpkg-perl, git, libosmocore-dev, libosmo-abis-dev, pkg-config, libsctp-dev
+Build-Depends: debhelper (>= 9),
+ autotools-dev,
+ autoconf,
+ automake,
+ libtool,
+ dh-autoreconf,
+ libdpkg-perl,
+ git,
+ libosmocore-dev,
+ libosmo-abis-dev,
+ pkg-config,
+ libsctp-dev,
+ libortp-dev
Standards-Version: 3.9.6
-Vcs-Git: git://git.osmocom.org/libosmo-netif.git
Vcs-Browser: http://git.osmocom.org/gitweb?p=libosmo-netif.git;a=summary
+Vcs-Git: git://git.osmocom.org/libosmo-netif.git
+Homepage: https://projects.osmocom.org/projects/libosmo-netif
Package: libosmonetif2
Section: libs
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}
Multi-Arch: same
-Description: Library containing common/shared code regarding network interface
+Description: Common/shared code regarding network interface for OpenBSC
+ The libosmo-netif library is one of the libraries needed by the
+ OpenBSC GSM infrastructure software. This library in particular implements
+ the shared code for network interfaces.
Package: libosmo-netif-dev
Section: libdevel
Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}, libosmocore, libosmonetif2 (= ${binary:Version})
+Depends: ${shlibs:Depends},
+ ${misc:Depends},
+ libosmocore-dev,
+ libosmocore,
+ libosmonetif3 (= ${binary:Version})
Multi-Arch: same
Description: Development headers for Osmocom network interface
+ The libosmo-netif library is one of the libraries needed by the
+ OpenBSC GSM infrastructure software. This library in particular implements
+ the shared code for network interfaces.
+ .
+ This package contains the development files needed for developing with
+ the libosmo-netif library.
Package: libosmo-netif-dbg
Section: debug
@@ -27,4 +53,9 @@ Architecture: any
Priority: extra
Depends: libosmonetif2 (= ${binary:Version}), ${misc:Depends}
Multi-Arch: same
-Description: Debug symbols for Osmocom network interface
+Description: Debug symbols for Osmocom network interface library
+ The libosmo-netif library is one of the libraries needed by the
+ OpenBSC GSM infrastructure software. This library in particular implements
+ the shared code for network interfaces.
+ .
+ This package contains the debug symbols for the library.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..1c1eb91
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,51 @@
+Format: http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Upstream-Name: libosmocore
+Source: git://git.osmocom.org/libosmo-netif.git
+
+Files: *
+Copyright: 2012-2013 On-Waves
+ 2012-2013 Pablo Neira Ayuso <pablo@gnumonks.org>
+License: GPL-2+
+
+Files: src/rs232.c
+Copyright: 2008-2011 Harald Welte <laforge@gnumonks.org>
+ Pablo Neira Ayuso <pablo@gnumonks.org>
+License: AGPL-3+
+
+Files: debian/*
+Copyright: 2013-2015 Holger Hans Peter Freyther <holger@moiji-mobile.com>
+ 2015 Ruben Undheim <ruben.undheim@gmail.com>
+License: GPL-2+
+
+
+License: GPL-2+
+ This package is free software: you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation, version 2 of the License, or
+ (at your option) any later version.
+ .
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+ .
+ You should have received a copy of the GNU General Public License
+ along with this program. If not, see <http://www.gnu.org/licenses/>.
+ .
+ On Debian systems, the complete text of the GNU General
+ Public License version 2 can be found in "/usr/share/common-licenses/GPL-2".
+
+
+License: AGPL-3+
+ This program is free software; you can redistribute it and/or modify
+ it under the terms of the GNU Affero General Public License as published by
+ the Free Software Foundation; either version 3 of the License, or
+ (at your option) any later version.
+ .
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+ .
+ You should have received a copy of the GNU Affero General Public License
+ along with this program. If not, see <http://www.gnu.org/licenses/>.
diff --git a/debian/rules b/debian/rules
index a4ddfaa..f398831 100755
--- a/debian/rules
+++ b/debian/rules
@@ -4,8 +4,9 @@ DEBIAN := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2)
DEBVERS := $(shell echo '$(DEBIAN)' | cut -d- -f1)
VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
#export DH_VERBOSE=1
-export DEB_BUILD_HARDENING=1
%:
@@ -21,3 +22,7 @@ override_dh_autoreconf:
override_dh_install:
dh_install
sed -i "/dependency_libs/ s/'.*'/''/" `find . -name '*.la'`
+
+override_dh_clean:
+ dh_clean
+ rm -f tests/package.m4 tests/testsuite .version .tarball-version