aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNeels Hofmeyr <nhofmeyr@sysmocom.de>2016-10-01 00:49:41 +0200
committerNeels Hofmeyr <nhofmeyr@sysmocom.de>2016-10-01 00:59:54 +0200
commitd0b6eb477712b707313dfb731e188ae5439b4cd0 (patch)
treee9b17904d1290ccdbf3aeab381692214b570c6e6 /configure.ac
parente168a1798bc9590d0c7c4f938e437cb9e74aaa53 (diff)
configure: check for pkg-config presence
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 135eb57..3994aff 100644
--- a/configure.ac
+++ b/configure.ac
@@ -18,6 +18,13 @@ AC_PROG_INSTALL
LT_INIT
AC_PROG_LIBTOOL
+dnl check for pkg-config (explained in detail in libosmocore/configure.ac)
+AC_PATH_PROG(PKG_CONFIG_INSTALLED, pkg-config, no)
+if test "x$PKG_CONFIG_INSTALLED" = "xno"; then
+ AC_MSG_WARN([You need to install pkg-config])
+fi
+PKG_PROG_PKG_CONFIG([0.20])
+
AC_CONFIG_MACRO_DIR([m4])
dnl checks for header files