aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2017-04-08 19:48:05 +0200
committerHarald Welte <laforge@gnumonks.org>2017-04-08 20:13:14 +0200
commitd0f9bd600c10615d9dbb6701001d491122a29aef (patch)
tree8cb0a22c0179359cbd8127fc65c056f0339608f2 /Makefile.am
parent5fe77a4656f3590c343861ea96bcec18e370e437 (diff)
Add minimal doxygen documentation for stream + datagram modules
We should have doxygen documentation for all libosmo-* APIs. libosmo-netif is currently devoid of any API docs. Let's start with the stream and datagram socket related functions. Change-Id: I589a5e60d9df2b8a65fbaf68f80e3ae0039d8c2a
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index a78c523..9b1c0f1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -13,3 +13,28 @@ $(top_srcdir)/.version:
echo $(VERSION) > $@-t && mv $@-t $@
dist-hook:
echo $(VERSION) > $(distdir)/.tarball-version
+
+
+if HAVE_DOXYGEN
+
+html_DATA = $(top_builddir)/doc/html.tar
+
+$(html_DATA): $(top_builddir)/doc/html/index.html
+ cd $(top_builddir)/doc && tar cf html.tar html
+
+$(top_builddir)/doc/html/index.html: $(SOURCES) Doxyfile
+ @rm -rf doc
+ mkdir -p doc
+ $(DOXYGEN) Doxyfile
+
+install-data-hook:
+ cd $(DESTDIR)$(htmldir) && tar xf html.tar && rm -f html.tar
+
+uninstall-hook:
+ rm -rf $(DESTDIR)$(htmldir)
+
+DX_CLEAN = doc/html/search/* doc/{html,latex}/* doc/html.tar doc/doxygen_sqlite3.db doc/*.tag
+
+endif
+
+MOSTLYCLEANFILES = $(DX_CLEAN)