aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAndreas Rottmann <a.rottmann@gmx.at>2015-05-17 20:06:44 +0200
committerHolger Hans Peter Freyther <holger@moiji-mobile.com>2015-05-19 11:47:01 +0200
commit87947aff533cd097a39a77772e127ac05f0de04b (patch)
treeafabca9284d286a28648c67a05b398556da206fa /Makefile.am
parentc713b1258714ef171de039c38bfdc2bf414ba9b7 (diff)
build: fix "make distcheck"
Running "make distcheck" failed trying to generate ".version" into the read-only unpacked source directory: make[1]: Entering directory '/tmp/build/libosmo-netif-0.0.4.10-7d1d/_build' echo 0.0.4.10-7d1d > ../.version-t && mv ../.version-t ../.version /bin/bash: ../.version-t: Permission denied Makefile:877: recipe for target '../.version' failed Actually shipping ".version" in the tarball fixes that.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 519d1ae..7b43d4d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,6 +6,8 @@ SUBDIRS = include src examples tests
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = libosmo-netif.pc
+EXTRA_DIST = .version
+
BUILT_SOURCES = $(top_srcdir)/.version
$(top_srcdir)/.version:
echo $(VERSION) > $@-t && mv $@-t $@