aboutsummaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index af8a9cf..c8b8996 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -5,7 +5,8 @@ AM_LDFLAGS = $(COVERAGE_LDFLAGS)
check_PROGRAMS = e1inp_ipa_bsc_test \
e1inp_ipa_bts_test \
ipa_proxy_test \
- subchan_demux/subchan_demux_test
+ subchan_demux/subchan_demux_test \
+ ipa_recv/ipa_recv_test
e1inp_ipa_bsc_test_SOURCES = e1inp_ipa_bsc_test.c
e1inp_ipa_bsc_test_LDADD = $(top_builddir)/src/libosmoabis.la \
@@ -25,6 +26,11 @@ subchan_demux_subchan_demux_test_LDADD = $(top_builddir)/src/libosmoabis.la \
$(LIBOSMOCORE_LIBS) $(LIBOSMOGSM_LIBS) \
$(LIBOSMOVTY_LIBS)
+ipa_recv_ipa_recv_test_SOURCES = ipa_recv/ipa_recv_test.c
+ipa_recv_ipa_recv_test_LDADD = $(top_builddir)/src/libosmoabis.la \
+ $(LIBOSMOCORE_LIBS) $(LIBOSMOGSM_LIBS) \
+ $(LIBOSMOVTY_LIBS)
+
# boilerplate for the tests
# The `:;' works around a Bash 3.2 bug when the output is not writeable.
$(srcdir)/package.m4: $(top_srcdir)/configure.ac
@@ -45,7 +51,8 @@ $(srcdir)/package.m4: $(top_srcdir)/configure.ac
} >'$(srcdir)/package.m4'
EXTRA_DIST = testsuite.at $(srcdir)/package.m4 $(TESTSUITE) \
- subchan_demux/subchan_demux_test.ok
+ subchan_demux/subchan_demux_test.ok \
+ ipa_recv/ipa_recv_test.ok
TESTSUITE = $(srcdir)/testsuite