aboutsummaryrefslogtreecommitdiffstats
path: root/include/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@osmocom.org>2020-05-11 08:38:51 +0200
committerHarald Welte <laforge@osmocom.org>2020-08-03 02:29:21 +0200
commit254b924536384d7ad2dc9ad4846aef3f5e45b71c (patch)
tree8d502b90e57f99aae6f35690b967429e143cb7ca /include/Makefile.am
parent1f9228434ebad84c3dd875d801337c2365a7901e (diff)
trau_frame: New API
The old TRAU frame code in src/trau_frame.c (which is for some strange reason part of libosmo-abis, and not libosmo-trau!) was introduced more than a decade ago for the needs of bs11_abis AKA OpenBSC aka OsmoNITB. It is too constrained to implement TRAU frame parsing in a generic way, including: * no way to add support for 8k sub-slots * no way to handle CRC bits or UFI (i.e. no AMR) * no real API design, it was just ripped out from OsmoNITB and moved into a library (even the wrong one) For those reasons, let's introduce a new API for TRAU frame encoding/decoding - one that supports all the relevant use cases. Change-Id: I5cf42e6c445d9224be18503cebc7584b3beba08c
Diffstat (limited to 'include/Makefile.am')
-rw-r--r--include/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/include/Makefile.am b/include/Makefile.am
index 2048520..aa735c5 100644
--- a/include/Makefile.am
+++ b/include/Makefile.am
@@ -4,4 +4,5 @@ nobase_include_HEADERS = osmocom/abis/ipa.h osmocom/abis/trau_frame.h \
osmocom/abis/ipa_proxy.h osmocom/abis/ipaccess.h osmocom/abis/abis.h \
osmocom/abis/subchan_demux.h osmocom/abis/e1_input.h \
osmocom/abis/lapd.h osmocom/abis/lapd_pcap.h osmocom/trau/osmo_ortp.h \
- osmocom/abis/unixsocket_proto.h
+ osmocom/abis/unixsocket_proto.h \
+ osmocom/trau/trau_frame.h