aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorEric Butler <eric@codebutler.com>2012-08-14 20:56:26 -0700
committerEric Butler <eric@codebutler.com>2012-08-14 20:56:26 -0700
commitd11a5c110355f86c7673777632cb797bf20722eb (patch)
tree6dd4683376536d5d83839cc1b90480c1ae5c08cc /debian/rules
parent91ffa2b5c1acf319b1c0e8f4a7f28aad63de7710 (diff)
Use package version since git info won't be available.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules8
1 files changed, 8 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 689c523..26d2880 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,8 +1,16 @@
#!/usr/bin/make -f
+DEBIAN := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2)
+DEBVERS := $(shell echo '$(DEBIAN)' | cut -d- -f1)
+VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
+
CFLAGS = -Wall -g
export DH_VERBOSE=1
%:
dh --with autoreconf $@ --fail-missing
+
+override_dh_autoreconf:
+ echo $(VERSION) > .tarball-version
+ dh_autoreconf