aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSylvain Munaut <tnt@246tNt.com>2019-05-09 11:14:26 +0200
committerHarald Welte <laforge@osmocom.org>2020-01-12 14:22:18 +0100
commitb559a5326371fa88dafd82d9fa6f9117442a6f70 (patch)
treefc2bc894225a3a4514af31e790eb3917e0567faf /configure.ac
parentb5af0991b39f5dc5e90cd5e36379631d389816be (diff)
e1d: Initial osmo-e1d support
osmo-e1d is part of the Osmocom 'software defined E1 interface, which consists of a USB device for the actual E1 hardware interfacing, and a daemon (osmo-e1d) implementing a libusb-based driver. This commit adds initial support for talking to osmo-e1d using the related libosmoe1d library. You need to use '--enable-e1d' at configure time to enable it. Change-Id: Ia0431c124e3b5b4108aee7b109d8c4bb0d8b45d4 Signed-off-by: Sylvain Munaut <tnt@246tNt.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 21 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5a83eb1..35b8328 100644
--- a/configure.ac
+++ b/configure.ac
@@ -75,6 +75,27 @@ else
AC_MSG_WARN([DAHDI input driver will not be built])
fi
+AC_ARG_ENABLE([e1d],
+ [AS_HELP_STRING(
+ [--enable-e1d],
+ [Enable osmo-e1d driver support]
+ )],
+ [
+ ENABLE_E1D=$enableval
+ ],
+ [
+ ENABLE_E1D="no"
+ ])
+AS_IF([test "x$ENABLE_E1D" = "xyes"], [
+ PKG_CHECK_MODULES(LIBOSMOE1D, libosmo-e1d)
+])
+AM_CONDITIONAL(ENABLE_E1D, test "x$ENABLE_E1D" = "xyes")
+AC_SUBST(ENABLE_E1D)
+if test x"$ENABLE_E1D" = x"yes"
+then
+ AC_DEFINE([HAVE_E1D], [1], [Enable osmo-e1d driver support])
+fi
+
AC_ARG_ENABLE(sanitize,
[AS_HELP_STRING(
[--enable-sanitize],