aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPau Espin Pedrol <pespin@sysmocom.de>2020-07-14 17:52:09 +0200
committerPau Espin Pedrol <pespin@sysmocom.de>2020-07-15 15:39:33 +0200
commit5196cd56415e9fa97d78b92ea1803606205710c4 (patch)
treee70dc0f22f6a07297ba38ce51ab3530fe1a8fe46 /configure.ac
parent837fb6e47113bf09d08ef8a79d4d466edd289404 (diff)
e1_input: Use osmo_use_count in e1inp_line
osmo_use_count is available since libosmocore 1.1.0 release, so bump required libosmocore version in autotools and packages. struct e1inp_line field refcnt is kept in order to keep ABI compatibility accessing struct fields. The new use_count is added at the end. Size of struct changing is fine since it is allocated through an API and a pointer should be used by clients. e1inp_line_clone API is changed but it's not used by anyone outside libosmo-abis, so it's fine. Related: OS#4624 Change-Id: I0658b2e9c452598025cc0f1d0b060076171767cc
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index f095cf5..04ffca6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -64,9 +64,9 @@ AC_SUBST(SYMBOL_VISIBILITY)
dnl Generate the output
AM_CONFIG_HEADER(config.h)
-PKG_CHECK_MODULES(LIBOSMOCORE, libosmocore >= 1.0.0)
-PKG_CHECK_MODULES(LIBOSMOVTY, libosmovty >= 1.0.0)
-PKG_CHECK_MODULES(LIBOSMOGSM, libosmogsm >= 1.0.0)
+PKG_CHECK_MODULES(LIBOSMOCORE, libosmocore >= 1.1.0)
+PKG_CHECK_MODULES(LIBOSMOVTY, libosmovty >= 1.1.0)
+PKG_CHECK_MODULES(LIBOSMOGSM, libosmogsm >= 1.1.0)
PKG_CHECK_MODULES(ORTP, ortp >= 0.22.0)
AC_ARG_ENABLE([dahdi],