aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNeels Hofmeyr <nhofmeyr@sysmocom.de>2016-10-01 00:48:43 +0200
committerNeels Hofmeyr <nhofmeyr@sysmocom.de>2016-10-01 00:59:19 +0200
commit24796f21475248f07884da8e22c2c9178f030a5d (patch)
tree9a4ac16a874fe76bae19866d8ba09370d65d6505 /configure.ac
parentf5d28602a73e7382e131f8772207b5caa2ea9c42 (diff)
configure: check for pkg-config presence
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 77feaff..f463c2e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -17,6 +17,13 @@ AC_PROG_CC
AC_PROG_INSTALL
LT_INIT([pic-only])
+dnl check for pkg-config (explained in detail in libosmocore/configure.ac)
+AC_PATH_PROG(PKG_CONFIG_INSTALLED, pkg-config, no)
+if test "x$PKG_CONFIG_INSTALLED" = "xno"; then
+ AC_MSG_WARN([You need to install pkg-config])
+fi
+PKG_PROG_PKG_CONFIG([0.20])
+
AC_CONFIG_MACRO_DIR([m4])
# The following test is taken from WebKit's webkit.m4