aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPablo Neira Ayuso <pablo@gnumonks.org>2014-02-20 18:43:15 +0100
committerPablo Neira Ayuso <pablo@netfilter.org>2014-02-20 19:41:29 +0100
commit14506665d982862e82b15d5f0b9578c213390515 (patch)
treebb8388e0bd4f755a4e1cf81da6e84bd6bef88ab4 /Makefile.am
add libgtpnl
This patch adds the libgtpnl library. Harald mentioned that he wanted that the specific code that is added is well encapsulated, so let's start a small library to interact with the GTP kernel module via netlink interface. This was done a bit while in the rush, so the interfaces are not nice at all and the tools need to be ported on top of this library. This library will be used to integrate openggsn with the GTP kernel module.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..cb72faf
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,11 @@
+include $(top_srcdir)/Make_global.am
+
+ACLOCAL_AMFLAGS = -I m4
+
+SUBDIRS = src include tools
+DIST_SUBDIRS = src include tools
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = libgtpnl.pc
+
+${pkgconfig_DATA}: ${top_builddir}/config.status