aboutsummaryrefslogtreecommitdiffstats
path: root/lib/rfspace/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/rfspace/CMakeLists.txt')
-rw-r--r--lib/rfspace/CMakeLists.txt20
1 files changed, 13 insertions, 7 deletions
diff --git a/lib/rfspace/CMakeLists.txt b/lib/rfspace/CMakeLists.txt
index c096550..eebc15d 100644
--- a/lib/rfspace/CMakeLists.txt
+++ b/lib/rfspace/CMakeLists.txt
@@ -1,19 +1,19 @@
# Copyright 2012 Free Software Foundation, Inc.
#
-# This file is part of gr-osmosdr
+# This file is part of GNU Radio
#
-# gr-osmosdr is free software; you can redistribute it and/or modify
+# GNU Radio is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
# the Free Software Foundation; either version 3, or (at your option)
# any later version.
#
-# gr-osmosdr is distributed in the hope that it will be useful,
+# GNU Radio is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
# GNU General Public License for more details.
#
# You should have received a copy of the GNU General Public License
-# along with gr-osmosdr; see the file COPYING. If not, write to
+# along with GNU Radio; see the file COPYING. If not, write to
# the Free Software Foundation, Inc., 51 Franklin Street,
# Boston, MA 02110-1301, USA.
@@ -21,11 +21,17 @@
# This file included, use CMake directory variables
########################################################################
-target_include_directories(gnuradio-osmosdr PRIVATE
+include_directories(
${CMAKE_CURRENT_SOURCE_DIR}
)
-list(APPEND gr_osmosdr_srcs
+set(rfspace_srcs
${CMAKE_CURRENT_SOURCE_DIR}/rfspace_source_c.cc
)
-set(gr_osmosdr_srcs ${gr_osmosdr_srcs} PARENT_SCOPE)
+
+########################################################################
+# Append gnuradio-osmosdr library sources
+########################################################################
+list(APPEND gr_osmosdr_srcs ${rfspace_srcs})
+#list(APPEND gr_osmosdr_libs ...)
+