aboutsummaryrefslogtreecommitdiffstats
path: root/lib/fcd/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/fcd/CMakeLists.txt')
-rw-r--r--lib/fcd/CMakeLists.txt35
1 files changed, 35 insertions, 0 deletions
diff --git a/lib/fcd/CMakeLists.txt b/lib/fcd/CMakeLists.txt
new file mode 100644
index 0000000..5d7d0c9
--- /dev/null
+++ b/lib/fcd/CMakeLists.txt
@@ -0,0 +1,35 @@
+# Copyright 2012 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+
+########################################################################
+# This file included, use CMake directory variables
+########################################################################
+
+include_directories(APPEND ${CMAKE_CURRENT_SOURCE_DIR})
+
+set(fcd_srcs
+ ${CMAKE_CURRENT_SOURCE_DIR}/fcd_source.cc
+)
+
+########################################################################
+# Append gnuradio-osmosdr library sources
+########################################################################
+list(APPEND gr_osmosdr_srcs ${fcd_srcs})
+list(APPEND gr_osmosdr_libs ${GNURADIO_FCD_LIBRARIES})
+