aboutsummaryrefslogtreecommitdiffstats
path: root/lib/uhd/CMakeLists.txt
diff options
context:
space:
mode:
authorEric Wild <ewild@sysmocom.de>2020-08-03 02:20:16 +0200
committerEric Wild <ewild@sysmocom.de>2020-08-03 02:20:16 +0200
commitdadabeceafdfb1c4b0487c8b20d79d47179f05b5 (patch)
tree5430a26ad49ec69ae57c251cf4565870faa9be7e /lib/uhd/CMakeLists.txt
parent5cf6f4df968f9fea1b28e437f25e855a13d6269f (diff)
cmake: actually make linking work
Appending to lists from subdirs does not work as expected, so work around that to allow collecting the necessary libs.
Diffstat (limited to 'lib/uhd/CMakeLists.txt')
-rw-r--r--lib/uhd/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/uhd/CMakeLists.txt b/lib/uhd/CMakeLists.txt
index db089f5..0ab6508 100644
--- a/lib/uhd/CMakeLists.txt
+++ b/lib/uhd/CMakeLists.txt
@@ -27,7 +27,7 @@ target_include_directories(gnuradio-osmosdr PRIVATE
${UHD_INCLUDE_DIRS}
)
-list(APPEND gr_osmosdr_libs
+APPEND_LIB_LIST(
gnuradio::gnuradio-uhd
${UHD_LIBRARIES}
)