aboutsummaryrefslogtreecommitdiffstats
path: root/lib/rtl_tcp/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri Stolnikov <horiz0n@gmx.net>2012-05-05 23:47:00 +0200
committerDimitri Stolnikov <horiz0n@gmx.net>2012-05-05 23:47:00 +0200
commitf94d8da48e84a5809c5aa0144f8d56c5da80e85d (patch)
tree7ce1397c20549c1a8372c0ed8d7c5c250ec9dd0b /lib/rtl_tcp/CMakeLists.txt
parent3a066ff25866999b611a9f7914c3da570616bc43 (diff)
rtl_tcp: add initial component files
For use with the rtl_tcp utility acting as a spectrum server. The "empty" rtl_tcp= device hint might be used to connect to rtl_tcp running on local machine.
Diffstat (limited to 'lib/rtl_tcp/CMakeLists.txt')
-rw-r--r--lib/rtl_tcp/CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/lib/rtl_tcp/CMakeLists.txt b/lib/rtl_tcp/CMakeLists.txt
new file mode 100644
index 0000000..df2a8e8
--- /dev/null
+++ b/lib/rtl_tcp/CMakeLists.txt
@@ -0,0 +1,36 @@
+# Copyright 2012 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+
+########################################################################
+# This file included, use CMake directory variables
+########################################################################
+
+include_directories(APPEND ${CMAKE_CURRENT_SOURCE_DIR})
+
+set(rtl_tcp_srcs
+ ${CMAKE_CURRENT_SOURCE_DIR}/rtl_tcp_source_f.cc
+ ${CMAKE_CURRENT_SOURCE_DIR}/rtl_tcp_source_c.cc
+)
+
+########################################################################
+# Append gnuradio-osmosdr library sources
+########################################################################
+list(APPEND gr_osmosdr_srcs ${rtl_tcp_srcs})
+list(APPEND gr_osmosdr_libs ${GNURADIO_CORE_LIBRARIES})
+