aboutsummaryrefslogtreecommitdiffstats
path: root/lib/bladerf/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri Stolnikov <horiz0n@gmx.net>2013-07-20 18:14:20 +0200
committerDimitri Stolnikov <horiz0n@gmx.net>2013-07-21 11:59:22 +0200
commite5f7b28093c10f05d272bcf12c6c4b6583af7021 (patch)
treeb82370206b2fe91aae99e78f7c4d67e47ed649b2 /lib/bladerf/CMakeLists.txt
parent0edfcfcba0ddf0fd5002dab70331d75a376bcf3f (diff)
bladerf: add support for nuand LLC bladeRF (WIP)
This is based on the original work (https://github.com/Nuand/gr-osmosdr) done by folks at nuand LLC for the gr3.6 branch of gr-osmosdr. The following modifications have been done in this commit: * port to gr-osmosdr master codebase (gr3.7) * moved shared properties to bladerf_common * added & verified IF filter bandwidth setters * set LMS6002D registers with values taken from FAQ 5.27 * print device information (serial/versions) on startup * added fpga= and fw= device arguments to program MCU/FPGA * added bladerf=# dev. arg. to select a specific bladeRF * grc gain field controls RF path VGA for RX/TX * grc BB gain field controls BB path VGA for RX/TX Usage example: osmocom_fft -a "bladerf,fpga=/tmp/hostedx115.rbf" The following RX named gain stages are available: LNA: 0 to 6 dB, in 3dB steps VGA1: 5 to 30 dB, in 1dB steps; nonlinear mapping done inside the lib VGA2: 0 to 60 dB, in 3dB steps; not recommended to be used above 30dB The following TX named gain stages are available: VGA1: -35 to -4 dB, in 1dB steps, BB side VGA2: 0 to 25 dB, in 1dB steps, RF side Thanks a lot to the team of nuand LLC for this major contribution.
Diffstat (limited to 'lib/bladerf/CMakeLists.txt')
-rw-r--r--lib/bladerf/CMakeLists.txt40
1 files changed, 40 insertions, 0 deletions
diff --git a/lib/bladerf/CMakeLists.txt b/lib/bladerf/CMakeLists.txt
new file mode 100644
index 0000000..23f7e3f
--- /dev/null
+++ b/lib/bladerf/CMakeLists.txt
@@ -0,0 +1,40 @@
+# Copyright 2013 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+
+########################################################################
+# This file included, use CMake directory variables
+########################################################################
+
+include_directories(
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${LIBBLADERF_INCLUDE_DIRS}
+)
+
+set(bladerf_srcs
+ ${CMAKE_CURRENT_SOURCE_DIR}/bladerf_source_c.cc
+ ${CMAKE_CURRENT_SOURCE_DIR}/bladerf_sink_c.cc
+ ${CMAKE_CURRENT_SOURCE_DIR}/bladerf_common.cc
+)
+
+########################################################################
+# Append gnuradio-osmosdr library sources
+########################################################################
+list(APPEND gr_osmosdr_srcs ${bladerf_srcs})
+list(APPEND gr_osmosdr_libs ${LIBBLADERF_LIBRARIES})
+