aboutsummaryrefslogtreecommitdiffstats
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri Stolnikov <horiz0n@gmx.net>2012-04-29 19:55:28 +0200
committerDimitri Stolnikov <horiz0n@gmx.net>2012-04-29 19:55:28 +0200
commitf0ac70fa41913f607db627d209e3cc85cf9ffd6f (patch)
tree6e05a30202ea06ddad0e3f1b15642f6b717cbc03 /lib/CMakeLists.txt
parent34baaf3f93e69bbc80382d3bc00cd67da0a3e4d2 (diff)
file: initial file source support
Example: file=/path/to/file.ext,freq=428e6,rate=1e6,repeat=true,throttle=true
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index f9efc41..4cd7fcc 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -67,6 +67,16 @@ GR_INCLUDE_SUBDIRECTORY(fcd)
endif(ENABLE_FCD)
########################################################################
+# Setup File component
+########################################################################
+include(GrComponent)
+GR_REGISTER_COMPONENT("File Source" ENABLE_FILE GNURADIO_CORE_FOUND)
+
+if(ENABLE_FILE)
+GR_INCLUDE_SUBDIRECTORY(file)
+endif(ENABLE_FILE)
+
+########################################################################
# Setup RTL component
########################################################################
include(GrComponent)