aboutsummaryrefslogtreecommitdiffstats
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri Stolnikov <horiz0n@gmx.net>2012-09-30 20:12:48 +0200
committerDimitri Stolnikov <horiz0n@gmx.net>2012-09-30 20:12:48 +0200
commit2878501284c9e0a85fd67cbf06f3a4f6c99336ad (patch)
treea3fc79c448b0a5c7c2b16ca46717ff82b130ed0e /lib/CMakeLists.txt
parentc51b04ee745d0c4c685c5a8cc15bcf83a9f1ab1f (diff)
add support for MSi2500 based DVB-T dongles through libmirisdr
this has been tested with analog modes only and still has to be verified with the usual digital modes for proper implementation.
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index 50c3387..494d498 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -108,6 +108,16 @@ GR_INCLUDE_SUBDIRECTORY(uhd)
endif(ENABLE_UHD)
########################################################################
+# Setup MiriSDR component
+########################################################################
+include(GrComponent)
+GR_REGISTER_COMPONENT("Osmocom MiriSDR" ENABLE_MIRI LIBMIRISDR_FOUND)
+
+if(ENABLE_MIRI)
+GR_INCLUDE_SUBDIRECTORY(miri)
+endif(ENABLE_MIRI)
+
+########################################################################
# Setup configuration file
########################################################################
ADD_DEFINITIONS(-DHAVE_CONFIG_H=1)