aboutsummaryrefslogtreecommitdiffstats
path: root/grc/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri Stolnikov <horiz0n@gmx.net>2013-04-28 12:36:03 +0200
committerDimitri Stolnikov <horiz0n@gmx.net>2013-04-28 12:36:31 +0200
commita5bdb272402fb012c0a97556cf50a69128e4c573 (patch)
tree5925f5a107df73daa5b4bf5df574098245b14cbb /grc/CMakeLists.txt
parent882b6da6ac42afd7381bdb89a6118d829f005a18 (diff)
hackrf: add TX support (wip)
features: - gain control for AMP & VGA - frequency error correction - automatic baseband filter - up to 20M sampling rate limitations: - no DC offset correction implemented (yet) - high sampling rates may not work on slow machines the following TX named gain stages are available: RF: MGA-81563, switchable 0 or 14dB IF: MAX2837 VGA, 0 to 47dB in 1dB steps
Diffstat (limited to 'grc/CMakeLists.txt')
-rw-r--r--grc/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/grc/CMakeLists.txt b/grc/CMakeLists.txt
index 0f253b5..aa15df3 100644
--- a/grc/CMakeLists.txt
+++ b/grc/CMakeLists.txt
@@ -34,7 +34,7 @@ endmacro(GEN_BLOCK_XML)
GEN_BLOCK_XML(gen_osmosdr_blocks.py rtlsdr_source_c.xml)
GEN_BLOCK_XML(gen_osmosdr_blocks.py osmosdr_source_c.xml)
-#GEN_BLOCK_XML(gen_osmosdr_blocks.py osmosdr_sink_c.xml)
+GEN_BLOCK_XML(gen_osmosdr_blocks.py osmosdr_sink_c.xml)
add_custom_target(osmosdr_grc_xml_blocks ALL DEPENDS ${xml_blocks})