aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri Stolnikov <horiz0n@gmx.net>2013-04-10 20:42:43 +0200
committerDimitri Stolnikov <horiz0n@gmx.net>2013-04-10 21:05:14 +0200
commitf5670788fc9cab640aa00833921313ee46583ae5 (patch)
tree296b1a039778abdc6606c3b891ce19c51520f5af /CMakeLists.txt
parentfd56ae76403097a7a8d246d2467b8a5a2912b8df (diff)
hackrf: add support for HackRF devices through libhackrf
features: - gain control for LNA & VGA - frequency error correction - automatic baseband filter - up to 20M sampling rate limitations: - no DC offset correction implemented (yet) - no RX preamplifier control (disabled by default) - high sampling rates may not work on slow machines
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a9334c8..bce201f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -116,13 +116,14 @@ find_package(GnuradioFCD)
find_package(LibOsmoSDR)
find_package(LibRTLSDR)
find_package(LibMiriSDR)
+find_package(LibHackRF)
if(NOT GRUEL_FOUND)
- message(FATAL_ERROR "Gruel required to compile osmosdr")
+ message(FATAL_ERROR "Gruel required to compile gnuradio-osmosdr")
endif()
if(NOT GNURADIO_CORE_FOUND)
- message(FATAL_ERROR "GnuRadio Core required to compile osmosdr")
+ message(FATAL_ERROR "GnuRadio Core required to compile gnuradio-osmosdr")
endif()
########################################################################