aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri Stolnikov <horiz0n@gmx.net>2013-05-01 13:51:35 +0200
committerDimitri Stolnikov <horiz0n@gmx.net>2013-05-01 13:51:35 +0200
commit59ceddbb749d0e43b0a85b677831a6896640f4e7 (patch)
tree7d65d5b9ddde7a56c485dd6b9d165fd4fdadd0a9 /CMakeLists.txt
parent1ae6a839bbf91140c441419cc0fbc50813884f59 (diff)
cmake: add boost thread & system dependencies again
thanks to Alberto Albiol for pointing this out.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ddcd3ba..41845d7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -63,6 +63,12 @@ ENDIF(CMAKE_COMPILER_IS_GNUCXX)
########################################################################
MESSAGE(STATUS "Configuring Boost C++ Libraries...")
+# Although not required on my system, some users have linking issues without
+SET(BOOST_REQUIRED_COMPONENTS
+ thread
+ system
+)
+
if(UNIX AND NOT BOOST_ROOT AND EXISTS "/usr/lib64")
list(APPEND BOOST_LIBRARYDIR "/usr/lib64") #fedora 64-bit fix
endif(UNIX AND NOT BOOST_ROOT AND EXISTS "/usr/lib64")
@@ -77,7 +83,7 @@ set(Boost_ADDITIONAL_VERSIONS
"1.65.0" "1.65" "1.66.0" "1.66" "1.67.0" "1.67" "1.68.0" "1.68" "1.69.0" "1.69"
)
-find_package(Boost)
+find_package(Boost COMPONENTS ${BOOST_REQUIRED_COMPONENTS})
if(NOT Boost_FOUND)
message(FATAL_ERROR "Boost required to build " ${CMAKE_PROJECT_NAME})