aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri Stolnikov <horiz0n@gmx.net>2013-02-10 18:13:44 +0100
committerDimitri Stolnikov <horiz0n@gmx.net>2013-02-10 18:13:44 +0100
commitd11b7a2614d8292168746050b9d197fba8981515 (patch)
treea40e8c9ef66e40f61ea6caa773048f7aea58adac /CMakeLists.txt
parent32dacffe84172547d068031f794c855f9a7b55f3 (diff)
fake gnuradio cpack behavior as long as we don't use it directly
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 17497bf..2571f8e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -190,6 +190,11 @@ IF(CMAKE_CROSSCOMPILING)
UNSET(GR_OSMOSDR_PC_LIBS)
ENDIF(CMAKE_CROSSCOMPILING)
+# fake gnuradio cpack behavior as long as we don't use it directly
+set(CPACK_PACKAGE_NAME "gnuradio-osmosdr")
+set(CPACK_PACKAGE_DESCRIPTION_SUMMARY "GNU Radio block for various radio hardware")
+set(CPACK_PACKAGE_VERSION ${VERSION})
+
CONFIGURE_FILE(
${CMAKE_CURRENT_SOURCE_DIR}/gnuradio-osmosdr.pc.in
${CMAKE_CURRENT_BINARY_DIR}/gnuradio-osmosdr.pc