aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri Stolnikov <horiz0n@gmx.net>2013-06-07 19:30:02 +0200
committerDimitri Stolnikov <horiz0n@gmx.net>2013-06-07 19:30:02 +0200
commit407be2c329ec4d8f929a0ff51a657285a1da1583 (patch)
tree4b5907cf6cf0532be3897fbfe416d238394cfc5f /CMakeLists.txt
parent86b906a0190f25412f66530a7afa325971f2dfe4 (diff)
cmake: add gnuradio-pmt dependency for OSX linkage
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fdd8cff..b45b292 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -143,7 +143,7 @@ set(GRC_BLOCKS_DIR ${GR_PKG_DATA_DIR}/grc/blocks)
########################################################################
# Find build dependencies
########################################################################
-set(GR_REQUIRED_COMPONENTS RUNTIME BLOCKS)
+set(GR_REQUIRED_COMPONENTS RUNTIME PMT BLOCKS)
find_package(Gnuradio "3.7.0")
find_package(GnuradioIQBalance)
find_package(UHD)
@@ -167,11 +167,15 @@ include_directories(
${CMAKE_SOURCE_DIR}/lib
${Boost_INCLUDE_DIRS}
${GNURADIO_RUNTIME_INCLUDE_DIRS}
+ ${GNURADIO_PMT_INCLUDE_DIRS}
+ ${GNURADIO_BLOCKS_INCLUDE_DIRS}
)
link_directories(
${Boost_LIBRARY_DIRS}
${GNURADIO_RUNTIME_LIBRARY_DIRS}
+ ${GNURADIO_PMT_LIBRARY_DIRS}
+ ${GNURADIO_BLOCKS_LIBRARY_DIRS}
)
# Set component parameters