aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri Stolnikov <horiz0n@gmx.net>2013-02-10 18:01:53 +0100
committerDimitri Stolnikov <horiz0n@gmx.net>2013-02-10 18:01:53 +0100
commit32dacffe84172547d068031f794c855f9a7b55f3 (patch)
treeb36c0e10ffafeb6bd0a3146e86e7a2062b3fc006 /CMakeLists.txt
parent91a93a39bca38dd6027bf37a34d86ade6f287c6c (diff)
Allows Unix systems with /usr/lib64 to use Boost installations in non-
this was taken from: http://gnuradio.org/cgit/gnuradio.git/commit/?id=648214ef4a77b5eb22f4e9715a7469ddc02583c1
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1b1e371..17497bf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -68,9 +68,9 @@ SET(BOOST_REQUIRED_COMPONENTS
system
)
-if(UNIX AND EXISTS "/usr/lib64")
+if(UNIX AND NOT BOOST_ROOT AND EXISTS "/usr/lib64")
list(APPEND BOOST_LIBRARYDIR "/usr/lib64") #fedora 64-bit fix
-endif(UNIX AND EXISTS "/usr/lib64")
+endif(UNIX AND NOT BOOST_ROOT AND EXISTS "/usr/lib64")
set(Boost_ADDITIONAL_VERSIONS
"1.35.0" "1.35" "1.36.0" "1.36" "1.37.0" "1.37" "1.38.0" "1.38" "1.39.0" "1.39"