aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri Stolnikov <horiz0n@gmx.net>2012-05-12 22:43:21 +0200
committerDimitri Stolnikov <horiz0n@gmx.net>2012-05-12 22:43:21 +0200
commit1097fd7aba08d6cc2e34b708922cee0008a94089 (patch)
tree4bd1a8fbac96a458e131cf084669a71c42bed5c8 /CMakeLists.txt
parent52dea1e0b7f47614c37c04d8f202f5ab458a9192 (diff)
cleanup cmake files, remove libusb module
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 0 insertions, 11 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c5a34cc..a409860 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -111,7 +111,6 @@ find_package(GnuradioCore)
find_package(GnuradioAudio)
find_package(GnuradioUHD)
find_package(GnuradioFCD)
-#find_package(LibUSB)
find_package(LibRTLSDR)
if(NOT GRUEL_FOUND)
@@ -122,14 +121,6 @@ if(NOT GNURADIO_CORE_FOUND)
message(FATAL_ERROR "GnuRadio Core required to compile osmosdr")
endif()
-if(NOT GNURADIO_AUDIO_FOUND)
- message(FATAL_ERROR "GnuRadio Audio required to compile osmosdr")
-endif()
-
-#if(NOT LIBUSB_FOUND)
-# message(FATAL_ERROR "LibUSB 1.0 required to compile osmosdr")
-#endif()
-
########################################################################
# Setup the include and linker paths
########################################################################
@@ -139,14 +130,12 @@ include_directories(
${Boost_INCLUDE_DIRS}
${GRUEL_INCLUDE_DIRS}
${GNURADIO_CORE_INCLUDE_DIRS}
-# ${LIBUSB_INCLUDE_DIR}
)
link_directories(
${Boost_LIBRARY_DIRS}
${GRUEL_LIBRARY_DIRS}
${GNURADIO_CORE_LIBRARY_DIRS}
-# ${LIBUSB_LIBRARY_DIRS}
)
# Set component parameters