aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHoernchen <la@tfc-server.de>2013-05-08 20:25:23 +0200
committerHoernchen <la@tfc-server.de>2013-05-08 20:25:23 +0200
commiteab1b6125338e473019b9f204762da0e7b388a74 (patch)
tree97dacd520bec4feacc9d04f732633df0fc03fc2b /CMakeLists.txt
parentaf819dfa4af838fb55ac4da299069156d7fbbf00 (diff)
hackrf: default to sse2 on x86/64
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 823fddd..e6685fc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -44,7 +44,11 @@ include(GrVersion) #setup version info
# Compiler specific setup
########################################################################
+IF(CMAKE_SYSTEM_PROCESSOR MATCHES "x86_64|AMD64|x86")
+ SET(USE_SIMD "SSE2" CACHE STRING "Use SIMD instructions")
+ELSE()
SET(USE_SIMD "no" CACHE STRING "Use SIMD instructions")
+ENDIF()
SET(USE_SIMD_VALUES "no" "SSE2" "AVX")
SET_PROPERTY(CACHE USE_SIMD PROPERTY STRINGS ${USE_SIMD_VALUES})
LIST(FIND USE_SIMD_VALUES ${USE_SIMD} USE_SIMD_INDEX)