aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJaroslav Škarvada <jskarvad@redhat.com>2013-04-14 17:24:43 +0200
committerSteve Markgraf <steve@steve-m.de>2013-04-14 17:35:18 +0200
commit2f6592566bd60d2539f5b976dcf6119876a0e02c (patch)
treef17cc555aacf03a24e23a79e3840811edd7d0dd0 /CMakeLists.txt
parentb999924d8e496152299cde1e10ed5fe31c61f686 (diff)
doxygen package needs to be detetected before the doxygen is used
Without this patch the DOXYGEN_EXECUTABLE is set too late which results in build failure when processing swig directory (with ENABLE_DOXYGEN). Signed-off-by: Jaroslav Škarvada <jskarvad@redhat.com> Signed-off-by: Steve Markgraf <steve@steve-m.de>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9e50023..915a347 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -115,6 +115,7 @@ find_package(LibOsmoSDR)
find_package(LibRTLSDR)
find_package(LibMiriSDR)
find_package(LibHackRF)
+find_package(Doxygen)
if(NOT GRUEL_FOUND)
message(FATAL_ERROR "Gruel required to build " ${CMAKE_PROJECT_NAME})