aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitri Stolnikov <horiz0n@gmx.net>2015-12-18 22:20:27 +0100
committerDimitri Stolnikov <horiz0n@gmx.net>2015-12-18 22:20:27 +0100
commit55fe96198733c9c57689d18e81cb2d7e8b2ebbfd (patch)
tree4b0c06ccd6fcfc725a3224199bf6ab723ea58cdf
parent3582ba17e0d7a5237c6393a1c5849533692018f7 (diff)
update documentation
-rw-r--r--README2
-rw-r--r--grc/gen_osmosdr_blocks.py7
-rw-r--r--lib/CMakeLists.txt4
3 files changed, 9 insertions, 4 deletions
diff --git a/README b/README
index ee5019e..bc995a6 100644
--- a/README
+++ b/README
@@ -11,10 +11,12 @@ as well supports:
* gnuradio .cfile input through libgnuradio-blocks
* RFSPACE SDR-IQ, SDR-IP, NetSDR (incl. X2 option)
* AirSpy Wideband Receiver through libairspy
+ * CCCamp 2015 rad1o Badge through libhackrf
* Great Scott Gadgets HackRF through libhackrf
* Nuand LLC bladeRF through libbladeRF library
* Ettus USRP Devices through Ettus UHD library
* Fairwaves UmTRX through Fairwaves' fork of UHD
+ * Red Pitaya SDR transceiver (http://bazaar.redpitaya.com)
By using the OsmoSDR block you can take advantage of a common software api in
your application(s) independent of the underlying radio hardware.
diff --git a/grc/gen_osmosdr_blocks.py b/grc/gen_osmosdr_blocks.py
index 174c591..36210f8 100644
--- a/grc/gen_osmosdr_blocks.py
+++ b/grc/gen_osmosdr_blocks.py
@@ -219,10 +219,12 @@ While primarily being developed for the OsmoSDR hardware, this block as well sup
* RFSPACE SDR-IQ, SDR-IP, NetSDR (incl. X2 option)
* AirSpy Wideband Receiver through libairspy
#end if
+ * CCCamp 2015 rad1o Badge through libhackrf
* Great Scott Gadgets HackRF through libhackrf
* Nuand LLC bladeRF through libbladeRF library
* Ettus USRP Devices through Ettus UHD library
* Fairwaves UmTRX through Fairwaves' fork of UHD
+ * Red Pitaya SDR transceiver (http://bazaar.redpitaya.com)
By using the osmocom $sourk block you can take advantage of a common software api in your application(s) independent of the underlying radio hardware.
@@ -253,6 +255,7 @@ Lines ending with ... mean it's possible to bind devices together by specifying
sdr-iq=/dev/ttyUSB0
airspy=0[,bias=0|1]
#end if
+ redpitaya=192.168.1.100[:1001]
hackrf=0[,buffers=32][,bias=0|1][,bias_tx=0|1]
bladerf=0[,fpga='/path/to/the/bitstream.rbf']
uhd[,serial=...][,lo_offset=0][,mcr=52e6][,nchan=2][,subdev='\\\\'B:0 A:0\\\\''] ...
@@ -297,11 +300,11 @@ Overall RF gain of the device.
IF Gain:
Overall intermediate frequency gain of the device.
-This setting is available for RTL-SDR and OsmoSDR devices with E4000 tuners and HackRF Jawbreaker in receive and transmit mode. Observations lead to a reasonable gain range from 15 to 30dB.
+This setting is available for RTL-SDR and OsmoSDR devices with E4000 tuners and HackRF in receive and transmit mode. Observations lead to a reasonable gain range from 15 to 30dB.
BB Gain:
Overall baseband gain of the device.
-This setting is available for HackRF Jawbreaker in receive mode. Observations lead to a reasonable gain range from 15 to 30dB.
+This setting is available for HackRF in receive mode. Observations lead to a reasonable gain range from 15 to 30dB.
Antenna:
For devices with only one antenna, this may be left blank.
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index 4ebc3e8..550c24e 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -195,7 +195,7 @@ endif(ENABLE_NONFREE)
########################################################################
# Setup HackRF component
########################################################################
-GR_REGISTER_COMPONENT("HackRF Jawbreaker" ENABLE_HACKRF LIBHACKRF_FOUND)
+GR_REGISTER_COMPONENT("HackRF & rad1o Badge" ENABLE_HACKRF LIBHACKRF_FOUND)
if(ENABLE_HACKRF)
GR_INCLUDE_SUBDIRECTORY(hackrf)
endif(ENABLE_HACKRF)
@@ -235,7 +235,7 @@ endif(ENABLE_SOAPY)
########################################################################
# Setup Red Pitaya component
########################################################################
-GR_REGISTER_COMPONENT("Red Pitaya support" ENABLE_REDPITAYA)
+GR_REGISTER_COMPONENT("Red Pitaya SDR" ENABLE_REDPITAYA)
if(ENABLE_REDPITAYA)
GR_INCLUDE_SUBDIRECTORY(redpitaya)
endif(ENABLE_REDPITAYA)