aboutsummaryrefslogtreecommitdiffstats
path: root/swig/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'swig/CMakeLists.txt')
-rw-r--r--swig/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/swig/CMakeLists.txt b/swig/CMakeLists.txt
index 7e9e888..22d7340 100644
--- a/swig/CMakeLists.txt
+++ b/swig/CMakeLists.txt
@@ -28,6 +28,12 @@ endif()
include(GrSwig)
include(GrPython)
+IF(${CMAKE_SYSTEM_NAME} MATCHES "Darwin")
+ # Mac OS X specific code
+ # Without this flag it does not find some of the libraries
+ SET(CMAKE_MODULE_LINKER_FLAGS "-undefined dynamic_lookup")
+ENDIF(${CMAKE_SYSTEM_NAME} MATCHES "Darwin")
+
########################################################################
# Setup swig generation
########################################################################