aboutsummaryrefslogtreecommitdiffstats
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt13
1 files changed, 9 insertions, 4 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index 680c41f..18619e3 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -28,14 +28,12 @@ list(APPEND grgsm_sources
receiver/receiver_impl.cc
receiver/receiver_config.cc
receiver/viterbi_detector.cc
- receiver/sch.c
+ decoding/sch.c
receiver/clock_offset_control_impl.cc
receiver/cx_channel_hopper_impl.cc
demapping/universal_ctrl_chans_demapper_impl.cc
demapping/tch_f_chans_demapper_impl.cc
decoding/control_channels_decoder_impl.cc
- decoding/cch.c
- decoding/fire_crc.c
decoding/tch_f_decoder_impl.cc
decoding/AmrCoder.cpp
decoding/BitVector.cpp
@@ -43,6 +41,12 @@ list(APPEND grgsm_sources
decoding/GSM660Tables.cpp
decoding/GSM503Tables.cpp
decoding/ViterbiR204.cpp
+ decoding/osmocom/coding/gsm0503_conv.c
+ decoding/osmocom/coding/gsm0503_coding.c
+ decoding/osmocom/coding/gsm0503_interleaving.c
+ decoding/osmocom/coding/gsm0503_mapping.c
+ decoding/osmocom/coding/gsm0503_parity.c
+ decoding/osmocom/coding/gsm0503_tables.c
flow_control/burst_timeslot_splitter_impl.cc
flow_control/burst_sdcch_subslot_splitter_impl.cc
flow_control/burst_timeslot_filter_impl.cc
@@ -73,7 +77,8 @@ list(APPEND grgsm_sources
add_library(grgsm SHARED ${grgsm_sources})
-target_link_libraries(grgsm ${Boost_LIBRARIES} ${GNURADIO_ALL_LIBRARIES} ${VOLK_LIBRARIES} ${LIBOSMOCORE_LIBRARIES}
+target_link_libraries(grgsm ${Boost_LIBRARIES} ${GNURADIO_ALL_LIBRARIES} ${VOLK_LIBRARIES} ${LIBOSMOCODEC_LIBRARIES} ${LIBOSMOCORE_LIBRARIES}
+# ${LIBOSMOCODING_LIBRARIES}
# libraries required by plotting.h - have troubles to be installed by pybombs
# boost_iostreams
# boost_system