aboutsummaryrefslogtreecommitdiffstats
path: root/dists/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'dists/debian/rules')
-rwxr-xr-xdists/debian/rules15
1 files changed, 15 insertions, 0 deletions
diff --git a/dists/debian/rules b/dists/debian/rules
new file mode 100755
index 0000000..cb59406
--- /dev/null
+++ b/dists/debian/rules
@@ -0,0 +1,15 @@
+#!/usr/bin/make -f
+DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
+export DEB_HOST_MULTIARCH
+
+%:
+ dh $@ --with python2 --parallel
+
+override_dh_auto_configure:
+ dh_auto_configure -- -DLIB_SUFFIX="/$(DEB_HOST_MULTIARCH)" -DPythonLibs_FIND_VERSION:STRING="2.7" -DPYTHON_EXECUTABLE:STRING="/usr/bin/python"
+
+override_dh_auto_install:
+ dh_auto_install
+ rm -f debian/gr-gsm/usr/lib/python2.7/dist-packages/grgsm/*pyc
+ rm -f debian/gr-gsm/usr/lib/python2.7/dist-packages/grgsm/*pyo
+