aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7a88ba6..c8fac31 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -93,6 +93,7 @@ find_package(Gnuradio)
find_package(Volk)
find_package(CppUnit)
find_package(Doxygen)
+find_package(Libosmocore)
if(NOT GNURADIO_RUNTIME_FOUND)
message(FATAL_ERROR "GnuRadio Runtime required to compile gr-gsm")
@@ -103,6 +104,9 @@ endif()
if(NOT CPPUNIT_FOUND)
message(FATAL_ERROR "CppUnit required to compile gr-gsm")
endif()
+if(NOT LIBOSMOCORE_FOUND)
+ message(FATAL_ERROR "Libosmocore required to compile gr-gsm")
+endif()
########################################################################
# Setup doxygen option
@@ -124,6 +128,7 @@ include_directories(
${Boost_INCLUDE_DIRS}
${CPPUNIT_INCLUDE_DIRS}
${GNURADIO_RUNTIME_INCLUDE_DIRS}
+ ${LIBOSMOCORE_INCLUDE_DIR}
)
link_directories(