aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bfbfe1a..16625f2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -155,13 +155,13 @@ endif()
if(NOT CPPUNIT_FOUND)
message(FATAL_ERROR "CppUnit required to compile gr-gsm")
endif()
+
+if(NOT LIBOSMOCORE_FOUND OR NOT LIBOSMOCODEC_FOUND OR NOT LIBOSMOGSM_FOUND)
+ set(LOCAL_OSMOCOM ON)
+endif()
+
if(LOCAL_OSMOCOM)
message(STATUS "Compiling with local osmocom libraries")
- unset(LIBOSMOCORE_FOUND)
- unset(LIBOSMOCODEC_FOUND)
- unset(LIBOSMOCODING_FOUND)
-elseif(NOT LIBOSMOCORE_FOUND OR NOT LIBOSMOCODEC_FOUND)
- message(STATUS "Compiling local version of libosmocore")
elseif(NOT LIBOSMOCODING_FOUND)
message(STATUS "Compiling local version of libosmocoding")
endif()