aboutsummaryrefslogtreecommitdiffstats
path: root/swig/CMakeLists.txt
diff options
context:
space:
mode:
authorptrkrysik <ptrkrysik@gmail.com>2014-08-14 14:57:10 +0200
committerptrkrysik <ptrkrysik@gmail.com>2014-08-14 14:57:10 +0200
commit6ecbfcaff9e0b11b80a05914d6b8405067f657f7 (patch)
tree00f069311081a0ec58a3c3c03af541fbb9c789b0 /swig/CMakeLists.txt
parent9750545e216142bb962dd2fe9cfa9e51d71b163e (diff)
Added check to cmake
Diffstat (limited to 'swig/CMakeLists.txt')
-rw-r--r--swig/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/swig/CMakeLists.txt b/swig/CMakeLists.txt
index 68ffd63..7c88fa2 100644
--- a/swig/CMakeLists.txt
+++ b/swig/CMakeLists.txt
@@ -18,6 +18,14 @@
# Boston, MA 02110-1301, USA.
########################################################################
+# Check if there is C++ code at all
+########################################################################
+if(NOT lol_sources)
+ MESSAGE(STATUS "No C++ sources... skipping swig/")
+ return()
+endif(NOT lol_sources)
+
+########################################################################
# Include swig generation macros
########################################################################
find_package(SWIG)