aboutsummaryrefslogtreecommitdiffstats
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorRoman Khassraf <roman@khassraf.at>2015-08-05 13:23:38 +0200
committerRoman Khassraf <roman@khassraf.at>2015-08-05 13:23:38 +0200
commite91edbdc119199c5028ff780943699117409ac74 (patch)
tree97532318b6ffdc5a7cdd9be52d1ec1f5990735a8 /lib/CMakeLists.txt
parent3ea373c3e29323487cf29e6ba27f3b3ca40d2a62 (diff)
parentc323454a3fbd8d617022ee309613f21c8b18d797 (diff)
Merged origin/msg-file-sink-source-101 into dev, fixed conflicts. Issue #101
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index c5fca8a..2278809 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -56,6 +56,8 @@ list(APPEND grgsm_sources
misc_utils/tmsi_dumper_impl.cc
misc_utils/burst_file_sink_impl.cc
misc_utils/burst_file_source_impl.cc
+ misc_utils/message_file_sink_impl.cc
+ misc_utils/message_file_source_impl.cc
qa_utils/burst_sink_impl.cc
qa_utils/burst_source_impl.cc
qa_utils/message_source_impl.cc
@@ -63,6 +65,7 @@ list(APPEND grgsm_sources
decryption/decryption_impl.cc
)
+
add_library(gnuradio-grgsm SHARED ${grgsm_sources})
target_link_libraries(gnuradio-grgsm ${Boost_LIBRARIES} ${GNURADIO_RUNTIME_LIBRARIES} ${VOLK_LIBRARIES} ${LIBOSMOCORE_LIBRARIES}
# libraries required by plotting.h - have troubles to be installed by pybombs