aboutsummaryrefslogtreecommitdiffstats
path: root/grc/CMakeLists.txt
diff options
context:
space:
mode:
authorVadim Yanitskiy <axilirator@gmail.com>2017-06-16 21:00:29 +0700
committerVadim Yanitskiy <axilirator@gmail.com>2017-07-07 22:12:52 +0700
commit89fc14ba44723cfbd88c2499ec8ab96ad993c5c4 (patch)
treebadecbb881fde1247b3f730f6dd47c3fccee5137 /grc/CMakeLists.txt
parent8f121c1e7c3e052ffcb63904f56de4eec7741dc2 (diff)
Implement transceiver interface
This change introduces a new block 'TRX Interface', which is aimed to provide an interface for external applications, such as Osmocom MS side stack implementation - OsmocomBB. Currently one allows to exchange raw GSM bursts between GR-GSM and other applications. Moreover, there is a new 'trx.py' application, which implements a simple follow graph, where all demodulated bursts are being sent to external application via UDP link provided by 'TRX Interface'. OsmoTRX (Osmocom's fork of OpenBTS transceiver) like control interface is used to initialize, configure, start and stop the application. Messages on this interface are human readable ASCII strings, which contain a command and some related parameters.
Diffstat (limited to 'grc/CMakeLists.txt')
-rw-r--r--grc/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/grc/CMakeLists.txt b/grc/CMakeLists.txt
index 2b94539..045d6a5 100644
--- a/grc/CMakeLists.txt
+++ b/grc/CMakeLists.txt
@@ -23,6 +23,7 @@ add_subdirectory(demapping)
add_subdirectory(receiver)
add_subdirectory(flow_control)
add_subdirectory(misc_utils)
+add_subdirectory(trx_interface)
install(FILES
gsm_block_tree.xml DESTINATION share/gnuradio/grc/blocks
)