aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Jesper Low Madsen <martin@martinjlowm.dk>2015-06-24 13:33:56 +0200
committerMartin Jesper Low Madsen <martin@martinjlowm.dk>2015-06-24 13:46:22 +0200
commitf3105d9585d9e7fc5322baff199799894109e650 (patch)
treec1544fe55e084dbfa8bd4263825293defe351e8c /CMakeLists.txt
parent9ee374b53e2149d77645a64b3aa2ff5cc0c89d14 (diff)
Include endian.h in cx_channel_hopper_impl and make burst_sink/source link Boost thread library
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0e92e87..7a88ba6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -58,7 +58,7 @@ set(Boost_ADDITIONAL_VERSIONS
"1.60.0" "1.60" "1.61.0" "1.61" "1.62.0" "1.62" "1.63.0" "1.63" "1.64.0" "1.64"
"1.65.0" "1.65" "1.66.0" "1.66" "1.67.0" "1.67" "1.68.0" "1.68" "1.69.0" "1.69"
)
-find_package(Boost "1.35" COMPONENTS filesystem system)
+find_package(Boost "1.35" COMPONENTS filesystem system thread)
if(NOT Boost_FOUND)
message(FATAL_ERROR "Boost required to compile gr-gsm")
@@ -162,6 +162,6 @@ add_subdirectory(docs)
########################################################################
# Install cmake search helper for this library
########################################################################
-install(FILES cmake/Modules/gr-gsmConfig.cmake
+install(FILES cmake/Modules/gr-gsmConfig.cmake
DESTINATION lib${LIB_SUFFIX}/cmake/grgsm
)