aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPiotr Krysik <ptrkrysik@gmail.com>2016-09-28 11:53:26 +0200
committerPiotr Krysik <ptrkrysik@gmail.com>2016-09-28 11:53:26 +0200
commitb516e6dcdb758d0b8ba513dbfe812d6e1ed4a0e5 (patch)
tree1fdc159584c23841325ddb3d6e4763a9d6af6b47 /CMakeLists.txt
parent679a9bd874685bcc95776e85ef0b78350d49008f (diff)
Moved control channels decoder to libosmocore implementation
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5832d42..11d589d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -107,6 +107,7 @@ find_package(Volk)
find_package(CppUnit)
find_package(Doxygen)
find_package(Libosmocore)
+find_package(Libosmocoding)
if(NOT GNURADIO_RUNTIME_FOUND)
message(FATAL_ERROR "GnuRadio Runtime required to compile gr-gsm")
@@ -120,6 +121,9 @@ endif()
if(NOT LIBOSMOCORE_FOUND)
message(FATAL_ERROR "Libosmocore required to compile gr-gsm")
endif()
+if(NOT LIBOSMOCODING_FOUND)
+ message(FATAL_ERROR "Libosmocoding required to compile gr-gsm")
+endif()
########################################################################
# Setup doxygen option